If only WebSphere Business Monitor Development Toolkit V7 installation on Windows Vista were smoother


After having struggled with the installation of IBM WebSphere Business Monitor Development Toolkit V7 on Windows 7, I decided to carry it on on a more supported platform and chose Windows Vista. It’s been more pleasant and I could finally install IBM Rational Application Developer V7.5.5.1 and IBM WebSphere Business Monitor Development Toolkit V7 with IBM WebSphere Business Monitor Server V7.0.0.3. It required to not install the fixes in WAS 7 package as they prevented from successful installation of the Monitor server.

It worked fine until I realized that IBM WebSphere Business Monitor Development Toolkit V7 had not been upgraded to 7.0.0.3 fix pack. It couldn’t since I did not let the installation manager to upgrade both package groups – the one with RAD and the other with Monitor server – at the same time having thought it would mess up the upgrade process (it quickly turned out to be a false thinking).

I downloaded the 7.0.0.3 fix pack for WebSphere Business Monitor Development Toolkit V7 – it could not be found in the registered online repositories from within IBM Installation Manager.

Fix pack 7.0.0.3 for WebSphere Business Monitor Development Toolkit V7

I registered the directory as a local repository in the repository list in IBM Installation Manager as described in Installing WebSphere Business Monitor development toolkit V7.0 Fix Pack 3 and pursued the Update.

Update packages (before) in IBM Installation Manager

After a few secs, it finished with the following panel though.

Update Packages in IBM Installation Manager

I even uninstalled IBM WebSphere Business Monitor 7.0.0.3 having hoped it would help somehow, but no joy – the same panel with “No updates or fixes…” as shown above.

Uninstall packages in IBM Installation Manager

It eventually made me think I don’t need IBM Rational Application Developer V7.5.5 at all and will rather go for IBM WebSphere Integration Developer V7 with Monitor Development Toolkit V7 installed. I wish I had known it before.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s