Troubleshooting WID 7.0.0.3 installation – UPDI required


It’s been a while since I worked with IBM WebSphere Integration Developer (WID) V7 on RedHat Enterprise Linux (RHEL) 5.5 as a VMware image so when I booted it up it turned out it needed Fix Pack 7.0.0.3 installation.

When I run Update in IBM Installation Manager (IM) it ended up with the following error message.

It recalled me the past experiences with updating IBM Rational Application Developer (RAD) 7.5 and WID 7 on MS Windows Vista that I worked around with renaming the directory with fixes in the installation CD. I couldn’t believe no one run across the issue and thought I’d google it.

It’s the configuration of the affected WTE installation.

[root@wid7 bi_v7]# pwd
/opt/IBM/WID7_WTE/runtimes/bi_v7
[root@wid7 bi_v7]# ./bin/versionInfo.sh -help
WVER0010I: Copyright (c) IBM Corporation 2002, 2005, 2008; All rights reserved.
WVER0012I: VersionInfo reporter version 1.15.1.26, dated 8/9/08

WVER0008I:
-format This option specifies the output format, either ''text'' or ''html''.
-file This option specifies an output file. A file name must be provided with the ''-file'' option.
-long This option causes all maintenance package and component information to be displayed.
-maintenancePackages This option causes maintenance packages to be displayed.
-maintenancePackageDetail This option causes maintenance package detail to be displayed.
-components This option causes components to be displayed.
-componentDetail This option causes component detail to be displayed.
-help This option causes help text to be displayed.
-usage This option causes this usage text to be displayed.
[root@wid7 bi_v7]# ./bin/versionInfo.sh -maintenancePackages
WVER0010I: Copyright (c) IBM Corporation 2002, 2005, 2008; All rights reserved.
WVER0012I: VersionInfo reporter version 1.15.1.26, dated 8/9/08

--------------------------------------------------------------------------------
IBM WebSphere Application Server Product Installation Status Report
--------------------------------------------------------------------------------

Report at date and time September 21, 2010 10:48:03 AM CEST

Installation
--------------------------------------------------------------------------------
Product Directory /opt/IBM/WID7_WTE/runtimes/bi_v7
Version Directory /opt/IBM/WID7_WTE/runtimes/bi_v7/properties/version
DTD Directory /opt/IBM/WID7_WTE/runtimes/bi_v7/properties/version/dtd
Log Directory /opt/IBM/WID7_WTE/runtimes/bi_v7/logs
Backup Directory /opt/IBM/WID7_WTE/runtimes/bi_v7/properties/version/nif/backup
TMP Directory /tmp

Product List
--------------------------------------------------------------------------------
WBI installed
XML installed
SCA installed
ND installed

Installed Product
--------------------------------------------------------------------------------
Name IBM WebSphere Process Server
Version 7.0.0.2
ID WBI
Build Level of1016.06
Build Date 4/22/10
Architecture Intel (32 bit)

Installed Product
--------------------------------------------------------------------------------
Name XML Feature Pack
Version 1.0.0.5
ID XML
Build Level cf051014.03
Build Date 4/6/10
Architecture Intel (32 bit)

Installed Product
--------------------------------------------------------------------------------
Name SCA Feature Pack
Version 1.0.1.5
ID SCA
Build Level cf051019.05
Build Date 5/15/10
Architecture Intel (32 bit)

Installed Product
--------------------------------------------------------------------------------
Name IBM WebSphere Application Server - ND
Version 7.0.0.7
ID ND
Build Level wps0946.04
Build Date 11/18/09
Architecture Intel (32 bit)

Installed Maintenance Package
--------------------------------------------------------------------------------
Maintenance Package ID 7.0.0.7-WS-WAS-LinuxX32-IFPK98944
Description WebSphere Application Server Cumulative iFix
Build Date 11/18/2009

Installed Maintenance Package
--------------------------------------------------------------------------------
...removed for simplicity's sake
--------------------------------------------------------------------------------
End Installation Status Report
--------------------------------------------------------------------------------
[root@wid7 bi_v7]# ./bin/versionInfo.sh -maintenancePackages |egrep -e IFPK98944 -e SDKPM00452
Maintenance Package ID 7.0.0.7-WS-WAS-LinuxX32-IFPK98944
Maintenance Package ID 7.0.0.x-SDKPM00452

There’re lots of packages displayed and those two ones were listed too.

After some time of reading a couple of documents about IM, the installation process for WID and other BPM products as well as googling for these two packages, I finally found a document Installation Instructions for IBM WebSphere Business Compass V7.0.0.0 Fix Pack 3 (7.0.0.3) where IFPK98944.pak was mentioned.

Any interim fixes that have been installed using the Update Installer (UPDI) must be removed with the Update Installer before starting V7.0.0 Fix Pack 3 activities. Two interim fixes were installed silently during the V7.0.0.0 install: SDKPM00452.pak and 7.0.0.7-WS-WAS-<platform><arch>-IFPK98944.pak. These will need to be removed, if you have not already done so.

It quickly occurred to me that I should install IBM Update Installer (UPDI) and uninstall the packages. I had never used UPDI this way, so with all the troubles, it was a quite nice addition to my toolbox machinery. I downloaded the current version of UPDI from IBM Update Installer V7.0.0.11 for WebSphere Software for Linux.

Run UPDI that already figured out what WAS I wanted to work with – it was the WTE from WID installation.

UPDI allowed me to pick the first package for uninstallation – SDKPM00452.pak.

Upon having selected the Next > button, it displayed what I was about to have uninstalled.

After a couple of minutes SDKPM00452.pak was gone.

I pressed the Relaunch button to go on with the other package – IFPK98944.

It might’ve turned out to have been more involved, but I merely noted it and moved on.

The second uninstallation was a bit longer – around twice as long as the former. IFPK98944 was gone.

After around 10 minutes, I was ready to launch the IM again and update the WID and WTE packages.

Another 1 hour and the installation finished with no failures or warnings.

As the last step in making sure all went fine I opened File > View Installed Packages where all the updates were listed.

I’m so happy again. On to reading the article Static and dynamic relationships in WebSphere Process Server and WebSphere ESB V7 at developerWorks.

Advertisements

2 responses to “Troubleshooting WID 7.0.0.3 installation – UPDI required

  1. Anonymous Coward

    Thanks this really helped.

  2. Maciej Szleminski

    Great tip. I had the exact same problem and this procedure worked like a charm. Kudos for posting this, this was the only thing Google found when I looked online for how to fix this problem.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s